rpm (legacy SFOS 3.4 – 4.2)

Rating: 
5
Your rating: None Average: 5 (3 votes)

in SFOS 4.5 jolla switched default rpm package compression to zstd. Older versions of SFOS need a zstd-enabled version of rpm to install those packages.
This is such a version for SFOS 3.4 - 4.2 (4.3 has had a update to rpm 4.16 and is not supported here)

sha256sum filename:
2d3d1f19465e3d42a1d6c2f0f9a66d8d6a3c0c91ecf0553fcc528318299ea136 rpm-4.14.3+git28-2.armv7hl.rpm
90d05286ac8b8a94dcc1b8cd5fc2328a83ad5e04632a5f83a993dc11c3213df7 rpm-build-4.14.3+git28-2.armv7hl.rpm
7294fda2ec7ebaa5540717623e484348d0d4707cb13afcf231ed7880db55071c rpm-devel-4.14.3+git28-2.armv7hl.rpm
31b0016ef49c3378a5f3b498ddf6afaa2da0865811dd7868c5c8f677b909d640 rpm-doc-4.14.3+git28-2.armv7hl.rpm
ce5e8f0ac55d098262ea97aa2b247f8b9a051194d7ee1681ffa45b97fcac2c09 rpm-libs-4.14.3+git28-2.armv7hl.rpm
a40bdee7083569429e90260287219c5e4a4ee7b66f7ce2efc7cf11f88035c696 rpm-sign-4.14.3+git28-2.armv7hl.rpm

Application versions: 
AttachmentSizeDate
File rpm-doc-4.14.1git28-1.armv7hl.rpm111.91 KB24/03/2024 - 17:58
File rpm-devel-4.14.1git28-1.armv7hl.rpm82.73 KB24/03/2024 - 17:58
File rpm-sign-4.14.1git28-1.armv7hl.rpm46.88 KB24/03/2024 - 17:58
File rpm-build-4.14.1git28-1.armv7hl.rpm109.07 KB24/03/2024 - 17:58
File rpm-4.14.1git28-1.armv7hl.rpm1.38 MB24/03/2024 - 17:58
File rpm-doc-4.14.3git28-2.armv7hl.rpm112.13 KB06/04/2024 - 19:23
File rpm-devel-4.14.3git28-2.armv7hl.rpm83.05 KB06/04/2024 - 19:23
File rpm-sign-4.14.3git28-2.armv7hl.rpm47 KB06/04/2024 - 19:23
File rpm-build-4.14.3git28-2.armv7hl.rpm108.88 KB06/04/2024 - 19:23
File rpm-4.14.3git28-2.armv7hl.rpm1.4 MB06/04/2024 - 19:23
Changelog: 

- update to rpm-4.14.3 [jsc#SLE-17817]
* add support for enforcing signature policy and payload
verification step to transactions
* add :humansi and :hmaniec query formatters for human readable output
* add query selectors –-whatobsoletes and –-whatconflicts
* add support for sorting caret (‘^’) higher than base version
- fix potential access of freed mem in ndb's glue code [bnc#1179416]
new patch: ndbglue.diff
- backport header check security fixes from upstream [CVE-2021-3421]
[CVE-2021-20271] [CVE-2021-20266]
[bsc#1183543] [bsc#1183545]
new patch: headerchk3.diff
- really fix symlink attacks on rpm install [bnc#943457]
[CVE-2017-7500]
- set default package verification level to 'none' to be compatible
to rpm-4.14.1
new patch: verifylevel_none.diff
- backport pgp hardening changes from upstream [bsc#1185299]
new patch: pgpharden.diff
- fix deadlock when multiple rpm processes try tp acquire the
database lock [bsc#1183659]
new patch: deadlock.diff
- backport zstd detection fix [bsc#1187670]
new patch: zstddetection.diff
- Backport header check changes so that old rpms get no longer
rejected [bsc#1190824]
updated patch: headerchk3.diff
- Revert unwanted /usr/bin/python -> /usr/bin/python2 change we
got with the update to 4.14.3 [bsc#1194968]
new patch: no-python2.diff
- Strip critical bit in signature subpackage parsing
* modified patch: pgpharden.diff