Glibc 2.30

Rating: 
0
No votes yet

!! JollaC/aquafish/INOI NOT SUPPORTED !! Snapdragon ‚Č• 400 required !!
derived from debian glibc-2.30-8 + glibc-git + mer-core-patches (git6)

before you proceed, take a look here: https://developers.redhat.com/blog/2016/02/17/upgrading-the-gnu-c-librar...

Known Issues: none (2.30)

The glibc package contains standard libraries which are used by
multiple programs on the system. In order to save disk space and
memory, as well as to make upgrading easier, common system code is
kept in one place and shared between programs. This particular package
contains the most important sets of shared libraries: the standard C
library and the standard math library. Without these two libraries, a
Linux system will not function.

Sha256sum / Filename:
b5bea08915a6dc35d0213543b9a459d5273ca85b5b4f8f17721b052b5ca1691e glibc-2.30+git6-8.armv7hl.rpm
5d66f0a73a381390229c99cf654f881a9cc0bba29ef0fba4575a540d9e6e00d8 glibc-common-2.30+git6-8.armv7hl.rpm
3433b591437470a8a5840d24f4a465d645c8349e2b1d3fd49c422feceeea9987 glibc-devel-2.30+git6-8.armv7hl.rpm
55e8caa3dfa6ac1531e9b1a610e7fc840bfee4562ae86bf60161895f9d265465 glibc-doc-2.30+git6-8.armv7hl.rpm
9ecfc2dbb1be02feddf8a475dc5c25d8c38bcc0ad8c95f97200f77cf8fe826f1 glibc-headers-2.30+git6-8.armv7hl.rpm
acbecbf53449fedc2565b59c6653e7cae0481cdf13bc1b1f1ab5aaefbad27937 glibc-static-2.30+git6-8.armv7hl.rpm
8a497fb8acdde1ea54f377a4dbf2eb4f8fddefec27f6ec4566a02d5ed5113ff8 glibc-utils-2.30+git6-8.armv7hl.rpm
710d61d9e64c1b3166d734137952b60d3143914e5340e11a725f5ebf70b97321 nscd-2.30+git6-8.armv7hl.rpm

Category:

Keywords:

Application versions: 
AttachmentSizeDate
File glibc-common-2.2310.1-2.armv7hl.rpm4.66 MB28/03/2018 - 18:26
File nscd-2.2310.1-2.armv7hl.rpm230.83 KB28/03/2018 - 18:26
File glibc-utils-2.2310.1-2.armv7hl.rpm40.33 KB28/03/2018 - 18:26
File glibc-static-2.2310.1-2.armv7hl.rpm1.57 MB28/03/2018 - 18:26
File glibc-headers-2.2310.1-2.armv7hl.rpm426.61 KB28/03/2018 - 18:26
File glibc-devel-2.2310.1-2.armv7hl.rpm80.06 KB28/03/2018 - 18:26
File glibc-2.2310.1-2.armv7hl.rpm5.59 MB28/03/2018 - 18:26
File glibc-common-2.25.6git1-1.armv7hl.rpm4.66 MB02/02/2019 - 11:58
File nscd-2.25.6git1-1.armv7hl.rpm229.44 KB02/02/2019 - 11:58
File glibc-static-2.25.6git1-1.armv7hl.rpm1.57 MB02/02/2019 - 11:59
File glibc-headers-2.25.6git1-1.armv7hl.rpm432.33 KB02/02/2019 - 12:01
File glibc-debug-2.25.6git1-1.armv7hl.rpm8.66 MB02/02/2019 - 12:07
File glibc-devel-2.25.6git1-1.armv7hl.rpm89.7 KB02/02/2019 - 12:07
File glibc-2.25.6git1-1.armv7hl.rpm5.64 MB02/02/2019 - 12:15
File glibc-common-2.30git6-8.armv7hl.rpm4.75 MB07/05/2021 - 04:09
File nscd-2.30git6-8.armv7hl.rpm63 KB07/05/2021 - 04:10
File glibc-static-2.30git6-8.armv7hl.rpm985.91 KB07/05/2021 - 04:11
File glibc-headers-2.30git6-8.armv7hl.rpm422.08 KB07/05/2021 - 04:11
File glibc-doc-2.30git6-8.armv7hl.rpm95.85 KB07/05/2021 - 04:11
File glibc-utils-2.30git6-8.armv7hl.rpm23.18 KB07/05/2021 - 04:12
File glibc-devel-2.30git6-8.armv7hl.rpm18.22 KB07/05/2021 - 04:13
File glibc-2.30git6-8.armv7hl.rpm2.27 MB07/05/2021 - 04:15
Changelog: 

!! JollaC/aquafish/INOI NOT SUPPORTED !!
vendor change from jolla-official requires command line install via pkcon, zypper or rpm...

- 2.30+git6-8 release: fixes CVE-2019-19126 CVE-2020-1752 CVE-2020-6096 CVE-2020-27618

- 2.25.6+git1 release

-2.23 release (experimental preview: it seems Jolla store-client will not launch anymore (so you have to go back to 2.19 to use it)):
Fixes MER#1633 : CVE-2014-9761
Fixes MER#1869 : CVE-2018-1000001 CVE-2017-15670 CVE-2017-16997 CVE-2017-15804 CVE-2017-1000409 CVE-2017-1000408
Fixes CVE-2017-12133